Gevey Ultra Wont Unlock iPhone 4 On Baseband 4.11.08 / 4.12.01 Anymore


by admin on May 1, 2012

Earlier we reported that Apple has fixes the vulnerability that caused SAM tool to unlock iPhone on any baseband. Before that we have told you that the new Gevey Ultra SIm can unlock iPhone 4 on baseband 4.11.08 and baseband 4.12.01 on iOS 5.1. Well it won’t unlock these basebands anymore.

The latest Gevey Ultra interposer was using the same vulnerability used for SAM unlock found by Loktar Sun. The developer released SAM unlock for free following the jailbreak community trend. On the other hand, Apple N Berry used his exploit and released their Gevey Sim at a price $49.99.

Applenberry accepted it and will refund the cost. This is what they have published on their blog:

gevey ultra iphone 4 unlock

Unfortunately, the GEVEY™ Ultra 5.1 for GSM iPhone 4 will no longer unlock the iPhone 4. The unlocking mechanism used in this model was based on Loktar Sun’s discovery of an Apple server logic error that took advantage of an ICCID bug to unlock the iPhone modem firmware. On April 27, Apple fixed this bug.

Apple N Berry, LLC is accepting returns for all GEVEY™ Ultra 5.1 for GSM iPhone 4 purchased on our website. Customers who haven’t received their shipment yet will automatically receive a full refund via their payment method chosen during checkout. Paypaly usually returns funds to user accounts within 10 days after we issue refunds.

All other GEVEY™ hardware unlock solutions continue to unlock their respective iPhone models. This recall is only for GEVEY™ Ultra 5.1 for GSM iPhone 4 SKU GV-00-0010.

Follow us on TWITTER or Like Facebook Page to get more updates on it.
We Write Very Rite

  • Carlos

    R-SIM 4 / this still works? is the same as the GEVEY Utlra (works with SAM)?

  • sanatic

    Hello I have an AT& T Apple iPhone 32GB 4
    OiS 5.1 Modem Firmware: 04.12.01, and was wondering what you should buy power Gevey Unblock.

Previous post:

Next post: