Unlock iPhone 4 Baseband 4.11.08 And Baseband 4.12.01 On iOS 5.1 With Gevey Ultra


by admin on April 24, 2012

UPDATEGevey Ultra Wont Unlock iPhone 4 On Baseband 4.11.08 / 4.12.01 Anymore

Earlier we have told you about the latest SAM unlock that can unlock iPhone 4 / 4S / 3GS running iOS 5.0.1 and later on any baseband.

Applenberry has also released new gevey ultra sim that can unlock iPhone 4 on baseband 4.11.08. Yes thats the same baseband which resulted in locked devices after users mistakenly updated their devices to iOS 5 without preserving baseband. Gevey Ultra can also unlock 4.12.01 on iOS 5.1 along with some old iPhone 4 basebands that it was already supporting. Complete list of supported bb are as follow:

  • 01.59
  • 02.10
  • 03.10.10
  • 04.10.10
  • 04.11.08
  • 04.12.01
gevey ultra iphone 4 unlock

Gevey Ultra can unlock all iOS version starting from iOS 4.1 up to the latest iOS 5.1. So if you are not up to AT&T’s term of unlocking and somehow you are unable to use SAM to unlock your device, then comes the GEVEY sim interposer as an option to unlock your iv4 device.

Its available for the order from Applenberry’s website at a price of $49.99.

Follow us on TWITTER or Like Facebook Page to get more updates on it.
We Write Very Rite

Previous post:

Next post: