Sn0wbreeze 2.5.1 Released Untethered 4.3.1 Jailbreak With Cydia 1.1.1, Boot Logos and Bug Fixes


by casey on April 7, 2011

As we have already told you about an upcoming version of Sn0wbreeze. iH8sn0w has released Sn0wbreeze 2.5.1 for untethered iOS 4.3.1 jailbreak. Previous version was Sn0wbreeze 2.5. Other than the mentioned features in changelog, its is exactly the same. Sn0wbreeze 2.5.1 can create custom firmware iOS 4.3.1 for iPhone 4, iPhone 3GS, iPhone 3G, iPod Touch 3G, iPod Touch 4G on Windows OS. Download links available below.

Here is the official changelog provided by the developer:

  • Cydia 1.1.1 is now pre-installed.
  • iPhone 3GS users can now flash the iPad 06.15.00 baseband.
  • Animate (Animated Boot Logos) by the Chronic Dev-Team is now supported.
  • Added afc2
  • Apple TV 2 is now fully supported.
  • Added Apple TV 2 DFU Instructions.
  • YouTube issues resolved on hacktivated devices.
  • iPhone 3GS old-bootrom issues fixed (Error 37).

The developer has also provided information for the Ultrasn0w users.

There is a temp. fix available on Pushfix’s Cydia repo (
for getting ultrasn0w to work on preserved basebands on 4.3.1.
[It does not fix the iPhone 4 single bar issue though!]

Sn0wbreeze Logo

Download Sn0wbreeze 2.5.1 Windows For Untethered 4.3.1 Jailbreak

HOW TO GUIDE for untethered iOS 4.3.1 jailbreak iPhone 4 3GS iPod Touch on Windows with Sn0wbreeze 2.5.1

Make sure you follow us. We cover all jailbreak and unlock news. Proof is our homepage

Follow us on TWITTER or Like Facebook Page to stay connected to get daily Internet News.

We Write Very Rite

  • jack

    i have iphone 3gs 4.2.1 bb 6.15.0, previously jailbroken by sn0wbreeze. Now when i am trying to update 4.3 after creating custom .ipsw using sn0wbreeze 2.5.1, it give thie error, ‘iphone firmware is corrupt”. Do anyone come across this and solved, please let me know.

Previous post:

Next post: