Install iOS 4.3 On iPhone 3G / iPhone 2G / iPod Touch 1G / iPod Touch 2G


by casey on March 18, 2011

Whited00r, a team which is known for their work to port iOS 4.0 on iPod Touch 1G and iPhone 2G has something new for us. Now they have successfully ported iOS 4.3 firmware for older iOS devices. Now you can install iOS 4.3 on iPhone 2G, iPhone 3G, iPod Touch 1G and iPod Touch 2G. Note that these devices are not officially supported by Apple to run the latest firmware.

iPod Touch 2G and iPhone 3G users have the choice to install iOS 4 or iOD 3 depending on their selection. Remember you can not install iOS4 or higher apps on it from the App Store.

Last but not the least, Whited00r is also intending to launch a lite version of iOS 4.3. So if you are curious enough to use iOS 4.3 on older devices may go and get Whited00r iOS 4.3 custom firmware.

whited00r install ios on iphone 2g ipod 1g

This is what they have updated on their site:

iPhone 3G and iPod touch 2G users can choose between iOS3 or iOS4 based firmware. Firmware on iOS3 is really faster then iOS4 based one, but you can’t install iOS4+ only apps from AppStore. We reccommend using iOS3 based firmwares since old device runs really slow on iOS4.

The tool is not released yet. We will update you as soon as they release it. Stay tuned to

You may also like to see:

Follow us on TWITTER or Like Facebook Page to stay connected to get daily Internet News.

We Write Very Rite

{ 2 comments… read them below or add one }

Kunal April 9, 2012 at 11:37 pm

I have iPhone 2g . I want to upgrade it to ios 4.1.3 can it be possible and if possible than how please reply


Martin March 4, 2014 at 8:47 pm

What most people want upgrading their devices to further versions of the system, is the ability to install new apps, such as snapchat or whatsapp – maybe, you could also enable versions of these apps for older iOS versions, besides disponibilizing higher iOS versions for older devices.
e.G. I have an iTouch1g with iOS 3.0, and would like to install certain apps that are only iOS 5.0 compatible


Leave a Reply

Your email address will not be published. Required fields are marked *

Previous post:

Next post: